.htaccessでphp_valueを使用したい時に必要なモジュール

ec-cubeを使用するのにphp_valueというものが必要らしい

Ansibleでec-cubeが動く環境を構築したのだけど、エラー発生。

apacheのエラーログを見るとこんなメッセージを吐いていました。

1
[Wed Mar 18 20:17:34.468955 2015] [core:alert] [pid 26855:tid 140431365052160] [client 192.168.33.1:58705] /vagrant/ec-cube/html/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration

どーやらモジュールが足りないらしい。ぐぬぬ。 またおまえか.htaccess。自重していただきたい。

とか愚痴をこぼすのはほどほどにサクッと拡張をインストール。これで使えるようになります。

ちなみ使用環境はubuntu14.04です。

1
sudo apt-get install libapache2-mod-php5

taskselなんかでサクッとLAMP環境を作るときには勝手に付いているので特に意識しなくてもいい。 Ansibleでとか、どうしてもtaskselできない事情があるときは上記のインストールコマンドをちゃんと追加しよう。